Why do I have Chinese characters on the App?

I used QPrompt v 1.0 last year and it worked well. I’m now needing prompting software again and so I’ve just downloaded v 1.1.6. I’m unsure if I understand why the app is showing all instructions and most of the words in English but I’m getting Chinese characters in places that don’t make any sense to me. I wasn’t given an option to install in any alternative language so I don’t get it. When I try to create a new document, I also get a mix of Chinese and English and I can’t figure any of this out. When I go into the early release of v 1.2, I’m getting some mention of a monthly fee. What’s going wrong here?

Hi @Jeff61,

That is a strange issue you’re having. Could you please provide to me the following details:

  1. What operating system are you running QPrompt on?
  2. What language is your Operating System configured to display apps in?
  3. Provide one or more screenshots or pictures of QPrompt showcasing your issue.

A few years ago I added support for multiple languages. The translations of which are contributed by our community over at [l10n](QPrompt @ Cuperino Apps Translations. Sometimes people will work on a translation and give up on the effort mid-way through for someone else to later pick up where they left off.

My suspicion is that what’s happening is your computer might be configured to display apps on a language that makes use of Chinese characters. QPrompt picked up on that fact and is displaying an incomplete translation for said language because the people behind it hadn’t finished it at the time QPrompt 1.1.6 released.

Alternatively, your computer might be configured to display apps on a language that doesn’t make use of Chinese characters, but the encoding of said language isn’t supported by QPrompt in your operating system, causing the app to display Chinese characters by mistake.

In order to know the true cause and address the issue for future versions, I will need you to answer the questions I’ve asked here. The answers to those questions will also help me guide you further.

As for the 1.2.0 access builds, those are relatively stable development builds that I create for people who are willing to support the project economically. In exchange they’re able to download early access builds. Unfortunately for everyone, the build pipeline used to create new builds broke, so the most recent development build dates Jul 30, 2023.

If you want the most recent build but you aren’t able to make a recurrent contribution, you can become a Patreon for a month, download the build, and cancel your subscription the same day. However, none of the development builds will fix your particular issue because translations were introduced long before those builds were created.

Your options are:

  1. Address the issue at the operating system level.
  2. Download an older version of QPrompt without support for translations.
  3. Launch QPrompt from a shell with a special command to enforce use of a specific language.

Please answer my questions above so I can give you further instructions on how to execute on these 3 options.


The laptop computer that this is happening on is owned by the university I work for so the OS would have likely been installed from a disk image that would have been flexible enough to permit folks from nearly any country in the world to use the resulting machine. It’s a W10 machine with I assume an enterprise version of W10. The OS is currently set to display in Australian English (UK English) with a US English keyboard setup. I’ve just installed the exact same QPrompt download on my own home machine that’s running a regular retail version of W11 that I installed myself. That should have the same Aussie/UK English settings, but the problem is not present for that machine. So you’re almost certainly right regarding the partial translations. The problem does not appear to be that I’m using Australian/UK English (fewer U’s and Z’s in words and some minor differences in punctuation but otherwise the same as US English) since the language settings should be the same on both machines. I just took a photo of the laptop’s installation since I don’t use that computer often and don’t have my regular screen capture software installed on it.

A language change option should be added to QPrompt anyway at some point.

Yes. Thank you for filing an issue about that on the issue tracker, @Liebeg : Change app language from inside the app · Issue #267 · Cuperino/QPrompt-Teleprompter · GitHub By filing it that way you can be sure I won’t forget about it.

Large reply coming? ?

Hi @Jeff61,

This is stranger than I thought… Thanks to the pictures I can tell the issue isn’t what I thought it was.

Many of the icons used throughout the QPrompt aren’t images but glyphs from a custom made font that I’ve made using https://fontello.com. That font is embedded then into QPrompt’s executable by means of the Qt Resource Compiler. Since the font is embedded, QPrompt should be having trouble in locating that font, but somehow it is unable to find it. All versions of QPrompt use fontello, including 1.0.

As my understanding goes, the text where fontello is used is not connected to the translation libraries in any way that would cause the font not to be found. Addressing this issue in any of the ways I originally proposed will not fix the issue

I don’t know what’s causing the issue or how to replicate it. We must be able to replicate it so it can be addressed.

I have two hypothesis currently:

  1. QPrompt’s installer may have gotten corrupted during download, due to an unstable connection, damaging something in the program that’s preventing the font from loading.
  2. This instance of Windows has been configured to have applications load with a different front. That might be overriding QPrompt’s font settings, resulting in Fontello not being used, so the icons are missing.

Could you try re-downloading, uninstalling, and re-installing the app? Try obtaining the installer from SourceForge first and if it doesn’t work, obtain it from GitHub.

If it continues to fail with both, that would mean this issue isn’t caused by data corruption of any kind.

In that case, look into Windows’ theme settings. If students have set a different theme or customized the theme’s fonts, resetting to the default theme with its default font might resolve the issue. If that happens to be the case, please provide me with the details on Windows theme settings so I can attempt to replicate.

Arnt you able to check if the installer is okay via a checksum?

Good idea @Liebeg . I can confirm the installers online are fine because their checksums match. Nevertheless, @Jeff61’s copy of the installer could still be the problem, so Jeff should either validate their copy of the installer with a checksum verification or re-download and re-install at least once to make sure that’s not the problem.

Here are checksums for qprompt-v1.1.6-51788eb-windows-cl-msvc2019-x86_64.exe

  • md5

  • sha1

  • sha256

  • sha515

I’ve now uninstalled and reinstalled from both sourceforge and from the exact same download as the one I used in my regular home machine that did work fine with the W11 home machine. Both sourceforge downloads plus the one that works fine with the windows 11 machine are still doing the same thing on the laptop. I’ve posted a screenshot of the what I get with the checksum verification. The first three seem to match, the sha515 says something about failing - I don’t know what exactly that means - but remember that this is a file that does install correctly on the W11 home desktop. I’ve looked at the installed fonts in both machine and neither seems to suggest that Fontello is installed. Remember that the machine on which Qprompt is working is a regular retail version of W11 where I installed myself and the only thing that might be different than others is that I asked it to install with Australian/UK english. The laptop where it’s not working correctly was a university machine that was likely installed from an enterprise version of W10. They have it configured in such a way that I’m still an administrator, but there are certain things that they can override (but almost nothing). I really don’t see any substantial differences in the laptop’s OS installation other than the fact that the University has overlayed their own name and their own inventory number along with an Image version number (Win 10.1.8) on the lower right of the screen. I can’t image how that might affect things, but thought I would mention it.

One checksum matching to one of the ones shared is enough to know for sure that the installer is fine. 515 is failing because you copied 515 and that was a typo I made, it was supposed to say 512. Sorry for the confusion.

You won’t find fontello anywhere because the font is not installed to the system or alongside the program, it is literally inside the program file that is QPrompt.exe, which is why it’s strange that QPrompt can’t find it.

The issue clearly has something to do with something that’s specific to that machine. One time we had a bug in QPrompt that only manifested itself in Windows 10 22H2 and no other version of Windows 10, 11, or any other OS was affected. That bug has long since been fixed and it holds no relation to this issue, but it did show that imperceptible differences in an operating systems’ inner workings could impact a program’s execution. If you can, try installing the latest Windows updates to see if it helps.

I have Windows 11, so I tried the following:

  • Set it to Australian English and deleted US English.
  • Set the Current System Locale to Australia.
  • Enable “Beta: Use Unicode UTF-8 for Worldwide language support”.
  • Set all normal Windows 11 themes.
  • Set all Windows 11 Accessibility / High Contrast themes.
  • Changed default Windows system font from Segoe UI to Comic Sans MS by means of a registry change.

With each of those changes QPrompt continued to work as expected, even after restarting. This leads me to believe this issue might only affect Windows 10 and earlier. Unfortunately I don’t own a Windows 10 license, and I don’t intend to buy one because Microsoft will stop shipping security updates for Windows 10 on October 15, 2025.

If you can think of any other settings I should look into, including things that require registry changes, please let me know.

I’ve filed an issue un our issue tracker so I don’t forget to follow up on this in the future. The issue is found here: Fontello failing to load on Australian Windows 10 system · Issue #268 · Cuperino/QPrompt-Teleprompter · GitHub

I could try something on my Windows 10 install after i am back from vaccation in 15 hours roughly. Just have to let me know what i should test.

@Liebeg Feel free to try all but the last of those bullet points. As for the last bullet point, you’re a technical person so I trust you can do it without messing up your system, but I would prefer less technical people not to mess with the Windows Registry as that could mess up their system.

Changing the location from austria to australia isnt a big change :rofl:

I filed a service request with the university and they have apparently found our discussion here on their own. They are telling me the following for what it’s worth. Some of this is just slightly over my head, but I get the general idea. I’ll likely check with them about the possibility of updating the laptop to Win11, which seems to be working. The remainder is what they told me by email.

From my testing:
• Windows 10 SOE is broken (as you know.)
• Windows 10 Vanilla is working.
• Windows 11 SOE is working.

I have also looked at compatibility settings and Defender settings, to no avail.
There are a lot of settings that have been set in the University’s Windows 10 SOE so I think it could be one of those them, but it is needle and haystack type search to locate it.
I might download the source code and QT Designer and build it in our environment to see if there are some errors during the build or something I can debug at runtime.

That would be great @Jeff61. The debug output will very likely tell us exactly what we need to know to address this.

This link contains instructions on how to build the program yourself: QPrompt-Teleprompter/build.md at v1.2 · Cuperino/QPrompt-Teleprompter · GitHub. Everything under KDE’s Craft build system is outdated and won’t work. We’re transitioning from using Craft to having build scripts of our own that give us more flexibility and consistency regarding which builds we can provide.

At the time of writing I’ve only gotten our new automated build script to work under Linux and MacOS, unless we finish adapting the script to Windows here, you’ll have to manually download and compile QPrompt’s dependencies as well, and install those alongside the build of the Qt framework you’d be compiling everything against. Only QPrompt’s required dependencies need to be compiled, optional dependencies are not needed for most of QPrompt’s functionality to work. Some dependencies will have sub-dependencies that you’d need to satisfy as well.

Which Qt version you’ll need will vary depending which branch of the program you want to build:

  • v1.1 Is the current stable branch for the version you’ve been using. This branch requires Qt 5.15.2 or a later version of Qt 5.
  • v1.2 Is the branch currently being used to create early access builds for Patreons This branch requires Qt 5.15.2 or a later version of Qt 5.
  • main Is our development branch our most recent changes and the only of these branches with our new build script (the one that presently only works on Linux and macOS). This branch requires Qt 6.7.0 or a later version of Qt 6.

You can take a look at how the new build script works here as reference: QPrompt-Teleprompter/setup.sh at main · Cuperino/QPrompt-Teleprompter · GitHub. You’ll need to have Python, Sphinx, and Bash installed to run this build script.

Here’s our list of dependencies and were clone them from. In the main branch, these all download automatically when you ask the git command to download submodules. You’ll need to clone the dependencies yourself for the other branches:

When installing KDE dependencies, make sure to checkout a stable version branch for each of their repositories. The branch must be the same for all of the dependencies. Choose a recent KDE branch for QPrompt’s main branch, and a branch 5.78.0 or a later 5.x version for QPrompt’s v1.1 and v1.2 branches.

Enable Development Mode on Windows, if you haven’t done so already: Enable your device for development - Windows apps | Microsoft Learn

QPrompt is built using the MSVC compiler. Install either Visual Studio 2019 or 2022 to get the compiler. Either Community or Commercial edition will work. Make sure the following components are selected at the minimum:

  • Desktop Development with C++
  • C++ ATL
  • Windows SDK

I hope this helps. Let me know if questions arise.

@Liebeg The last bullet refers to changing system fonts. Microsoft removed that feature from Windows. Nevertheless, a user could’ve still changed setting, either by manipulating the Windows registry or through Windows settings, if this was an earlier version of Windows that got upgraded to Windows 10.

Microsoft taking away Features always makes me so happy. Damm i should switch to Linux.

Depending on the profession, and the things you enjoy doing, that is actually a good idea for many, many, people. QPrompt, being build mostly with libraries from a Linux desktop, is also way easier to build on Linux: you can run 1 install command to satisfy all required dependencies, then proceed straight to building the app.

To be clear, I’m speaking of normal Linux desktops running on your system. If you try WLS, it won’t work properly due to bugs in WSL that cause various solids and all transparencies to render black. Performance is also sub-optimal for a teleprompter in WSL.

Also, since QPrompt supports every well known Linux universal packaging format, it is also available for free in stores from most popular Linux distributions.